dram.me

关于兼容性和发展

Lua语言版本在不断更迭,现在已经到5.3版本,而LuaJIT则一直停留在5.1。究其原因,很重要的一点是LuaJIT作者出于兼容性的考量(以及对于5.3版本功能实现的不满)。

由此,Lua社区因为版本问题被割裂。对于这个问题,有过很多的讨论,例如这篇博文,以及HN上的讨论。未来会如何发展,存在很大的不确定性。